Axis Customer Forum

It is currently Fri Oct 19, 2018 1:24 pm

All times are UTC




Post new topic Reply to topic  [ 2 posts ] 
Author Message
PostPosted: Tue Apr 10, 2018 3:30 pm 

Joined: Mon Mar 06, 2017 1:20 pm
Posts: 2
We are using M7016 to stream video. We are embedding the image in a browser. We have included the username/password in the URL as we don't want to allow anonymous access. This works fine in Mozilla Firefox but does not work with Chrome or Edge.

Here is the code we're using:

<html>
<body>
<center>
<a name="camstream"></a>
<div class="detailcenter">
<a rel="nofollow" href="http://USERNAME:PASSWORD@IP_ADDRESS/mjpg/1/video.mjpg?camera=3" target="new"><img id="image0" src="http://USERNAME:PASSWORD@IP_ADDRESS/mjpg/1/video.mjpg?camera=3"</a>
<script>
var ch = 0;
var imageurls = new Array();
imageurls[0] = new String("http://USERNAME:PASSWORD@IP_ADDRESS/mjpg/1/video.mjpg?camera=3");
</script>
<BODY onselectstart="return false;" ondragstart="return false;">
</html>

Any suggestions?

Thank you!

Sean


Top
 Profile  
 
PostPosted: Fri Apr 13, 2018 6:53 am 

Joined: Fri Nov 14, 2014 1:38 am
Posts: 632
Passing plain user id and password is not allow in Chrome or IE.

If you are interested in further discussion, please contact me via Skype @ Cheng.Xin.SG


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Powered by phpBB® Forum Software © phpBB Group