Axis Customer Forum

It is currently Mon Sep 23, 2019 8:41 pm

All times are UTC




Post new topic Reply to topic  [ 3 posts ] 
Author Message
PostPosted: Tue Jun 20, 2017 10:04 am 

Joined: Tue Jun 20, 2017 10:00 am
Posts: 1
Hi,

While developing an application around the Axis Demographics application I noticed that the API is unusable from within any browser.
For alls the available API calls the "Access-Control-Allow-Origin" headers aren't returned causing browsers to reject returned data.

Conclusion, the API request work when coming from a server but nothing can be done with it within a webapplication/website.

Anyone else hitting this issue? Any chance this can be fixed soon?

Thanks a lot!

Bo


Top
 Profile  
 
PostPosted: Thu Jan 11, 2018 2:22 pm 

Joined: Thu Jan 11, 2018 2:15 pm
Posts: 1
worked fine with me when i was working on the official web page project..i guess it has been fixed already or probably it as just a one time occurrence


Top
 Profile  
 
PostPosted: Wed Sep 11, 2019 11:10 am 

Joined: Mon Sep 02, 2019 11:20 am
Posts: 3
They do not work. Camera APIs do not have the option to return CORS headers.

I would hope the camera firmware engineers do read this forum posts. CORS has been around for many years, can't believe this platform do not know about it. We cant use apis like ptz.cgi from our solutions without using some kind of local reverse proxy


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
cron
Powered by phpBB® Forum Software © phpBB Group